获取人物坐标,对控制人物事件有着重要的作用(续)

找猫的老鼠   2017-07-04 08:17

前言:对于昨天发的文章在此我深表歉意,由于昨天时间比较张没有来的及给大家解释,所以今天特意来详细讲解一下。

第一步:今天用的是天使插件(设计:一个组合框,5个按钮,前期的工作还是要绑定窗口的,大家先看一下设计窗口)

获取人物坐标,对控制人物事件有着重要的作用(续)

设计窗口

第二步:咱们来看一下绑定窗口事件(这里绑定窗口主要用到了 进程数量 = 进程_枚举 (进程名数组, 进程ID数组) 要 计次循环首 (进程数量, i) 把要用的窗口绑定到 组合框里面,具体看下面图片和代码)

获取人物坐标,对控制人物事件有着重要的作用(续)

寻找窗口1

获取人物坐标,对控制人物事件有着重要的作用(续)

子程序(寻找窗口)

第三步:我们看一下怎么样绑定窗口(用到的是这个:BindWindow (Hwnd, “gdi”, “windows”, “windows”, 101) 不了解的大家可以百度一下)

获取人物坐标,对控制人物事件有着重要的作用(续)

窗口绑定

获取人物坐标,对控制人物事件有着重要的作用(续)

暂停,恢复,结束脚本

第四步:我们来看一下怎么获取人物坐标 这个我用到了找色 TS.FindColor (280, 121, 741, 437, “ff003”, 0.9, 4, ZX, ZY) 解释:280, 121, 741, 437 人物周边的坐标,可以用大漠工具抓图找到, “ff003”这个是血量的颜色,0.9是相似值相对于血量的颜色值来说的,ZX,ZY是变体型。来具体看一下代码:

获取人物坐标,对控制人物事件有着重要的作用(续)

人物坐标

具体代码如下:

.版本 2

.支持库 xplib

.支持库 spec

.支持库 EThread

.程序集 窗口程序集1

.程序集变量 TS, 类_天使

.程序集变量 窗口数组, 整数型, , "0"

.程序集变量 许可证, 线程许可证

.程序集变量 Hwnd, 整数型

.程序集变量 线程句柄, 整数型

.程序集变量 i, 整数型

.程序集变量 k, 整数型

.子程序 __启动窗口_创建完毕

.局部变量 返回值, 整数型

XP风格 (1)

寻找窗口 (“Game.dat”)

返回值 = TS.SetPath (取运行目录 ())

调试输出 (“设置全局录制返回值:”, 返回值)

.子程序 寻找窗口

.参数 进程名, 文本型

.局部变量 进程名数组, 文本型, , "0"

.局部变量 进程ID数组, 整数型, , "0"

.局部变量 进程数量, 整数型

.局部变量 i, 整数型

进程数量 = 进程_枚举 (进程名数组, 进程ID数组)

.计次循环首 (进程数量, i)

.如果真 (进程名数组 [i] = 进程名)

加入成员 (窗口数组, 进程_ID取窗口句柄 (进程ID数组 [i]))

.如果真结束

处理事件 ()

.计次循环尾 ()

.如果真 (取数组成员数 (窗口数组) > 0)

.计次循环首 (取数组成员数 (窗口数组), i)

组合框1.加入项目 (“第” + 到文本 (i) + “窗口,标题:” + 窗口_取标题 (窗口数组 [i]), )

.计次循环尾 ()

组合框1.现行选中项 = 0

.如果真结束

.子程序 _按钮1_被单击

.局部变量 绑定值, 整数型

Hwnd = 窗口数组 [组合框1.现行选中项 + 1]

绑定值 = TS.BindWindow (Hwnd, “gdi”, “windows”, “windows”, 101)

调试输出 (“窗口绑定返回值:”, 绑定值)

.如果 (绑定值 = 1)

许可证 = 线程_创建许可证 ()

线程句柄 = 线程_启动 (&多线程, , )

.否则

信息框 (“窗口绑定失败”, 0, )

.如果结束

.子程序 _按钮2_被单击

.如果真 (线程句柄 > 0)

线程_挂起 (线程句柄)

.如果真结束

.子程序 _按钮3_被单击

.如果 (线程句柄 > 0)

线程_恢复 (线程句柄)

.否则

.如果结束

.子程序 _按钮4_被单击

.局部变量 返回值, 整数型

.如果真 (线程句柄 > 0)

返回值 = TS.UnBindWindow ()

调试输出 (“窗口解除绑定返回值:”, 返回值)

线程_退出许可区 (许可证)

线程_删除许可证 (许可证)

强制结束线程 (线程句柄)

.如果真结束

.子程序 多线程

.局部变量 ZX, 变体型

.局部变量 ZY, 变体型

.局部变量 序号, 整数型

线程_进入许可区 (许可证)

.计次循环首 (100, k)

序号 = TS.FindColor (280, 121, 741, 437, “ff003”, 0.9, 4, ZX, ZY)

调试输出 (“人物坐标返回值:”, 序号)

.如果真 (序号 > -1)

程序_延时 (100)

调试输出 (“人物坐标:”, ZX.取数值 (), “/”, ZY.取数值 ())

跳出循环 ()

.如果真结束

.计次循环尾 ()

' 首先 确定人物坐标

.子程序 _按钮5_被单击

' TS.Capture (0, 0, 1024, 768, “测试.bmp”)

谢谢大家留言互粉!

内容推荐
更多阅读

· 两个省当过省委书记,他在中纪委办案点过了66周岁生日

· 为金马影帝谢君豪和被低估的演技派万茜,疯狂打call!

· 原华平投资亚太区主席孙强重回私募业 履新TPG中国区管理合伙人

· 90岁抗战老兵孟庆玉:“给我一把枪,我还可以上战场杀日本鬼子”

· Elie Saab高定秀场,奢侈华丽的亲子装,这辈子是没机会穿了

· 邻近又遥远 真实的俄罗斯远东地区什么样

· 埃塞俄比亚七宗“最”

· 三个国家争夺领土,一个国家发话:我有中国血统,结果不出所料!

· 87㎡简约混搭三居室样板房设计

· 十一黄金周:中国游客出发在即 欧洲这些国家已经准备好了

· 海康威视副董事长龚虹嘉减持1.16%股份,套现31亿元

· 辞职后公司不发工资如何处理

· 现在拥有多少财富,才能赶得上30年前的“万元户”?

· 当之无愧的狼王,27年打造中国自己的名牌,一天订单超8000万!

· 美国估计解决不了艾滋病啦!因为特朗普的艾滋病顾问又双叒叕辞职啦!

· 中国驻比利时使馆举行招待会庆祝新中国成立68周年

· 赵丽颖外网无修图,这是黑子吗?

· 阑尾炎术后不能吃什么 有什么注意事项?

· 草莓遇上蛋糕,美味颜值担当

· 一条腿老师的坚守,他用两根拐杖撑起校园,是孩子们最后的希望

· 以心至诚 志在伟霖 雷克萨斯芜湖伟霖开业典礼荣耀展开

· 办合约买iPhone8值不值?国内三大运营商套餐大PK

· 罗技发布Screen Share,可以在会议中分享内容

· 两连败导致出局?数据表明多特晋级概率只有9%

· 陇神戎发:五名董监高拟合计减持逾146万股

· 昨夜今晨全球大公司动态:雀巢可能将占营收约10%的资产转换出去

· 识不足则多虑,威不足则多怒,信不足则多言

· 完美的艺术品 2018款 兰博基尼Aventador

· 80㎡温馨小日式,大气简约功能俱全,看完都想要!

· “年度造假公司”的改邪归正史:靠停牌与编故事养成300亿市值

· 共享充电宝公司花样裁员 创始人:不知道,我是个假CEO

· B2B线上采购平台Power2SME获3600万美元E轮融资

· 永达汽车(03669)可换股债获兑换 折价27.39%发行约95.66万股

· 火箭军部队大动作:罕见公开多枚长剑10巡航导弹齐射超猛

· 辅食添加苹果有讲究 宝宝多大可以吃苹果

· 校名有点野鸡,但实力却很强的211大学校园是什么样的?

· 韭菜花4毛一斤,韭叶成堆白送没人要,怕烂地里只能往高速路上扔

· 高大上的大学餐厅菜品丰富价格便宜 为啥那么多同学还要叫外卖?

· 它是丝绸之路上最大的佛寺遗址!被誉为“宁夏敦煌”!

· 双节将至 农村大集上几道下酒的稀罕美食有的排队购买 您吃过几种

· 风之伊,魔兽世界的锤子,先发个素体

· 心疼!每天几百条活鳗鱼都让深圳这家奇葩店给糟蹋了……

· 面对残阵丢分 利物浦问题出在哪里 克洛普该不该背锅?

· 热身赛:辽宁多主力缺阵73-54轻取塞尔维亚,赵率舟5记三分砍23分

· 首集像大结局,史上死最快最多明星的电视剧!

· 甜瓜生涯13%的比赛首发大前锋,场均得分20年最高

· 给大家推荐一款以魔兽为背景的手游《我叫MT4》

· 2种中药注射剂被紧急召回!频繁搞事情,中药注射剂的bug出在这里

· 钟南山院士:治特发性肺纤维化,终于又出了一种新药了

· 阳光射进森林

· 奶牛改变了他身上的陋习 他从奶牛身上一年“挤”出一个10 万

· 2岁被领养 中国女孩代表美国参加世锦赛

· 张家口西环外的山旮旯里的小区是这样的!

· 9部烧脑神剧,看完智商都提高了一大半

· 千元备用机的最佳选择 红米4X+无线流量卡

· 比十一黄金周的景区还挤的,是十一黄金周的档期啊!

· 这个皇帝刚上位,就收拾了3000多人,却放过了他的杀母仇人

· 南极洲海冰面积创新低 科学家:运输业风险逐渐升高

· 用“陨铁”来打造,那有多让人羡慕

· 原来金刚石薄膜这么好用,你知道吗?

· 美人图赏:旗袍是个伟大的发明,你的美惊艳了时光

· 黄金烤猪现身菜市场 38块钱一斤 一天只卖一头 引市民热购

· 看看这些名人们流落人间的“双胞胎”兄弟姐妹,不止神似

· 水做的摄影师!20张震撼心灵的史诗般水体摄影作品

· 北岳恒山,中国十大名山之一,值得一去

· 途观销量为何大不如从前,看看车主如何评价?

· 事实证明,近些年的联盟西强东弱都是因为詹姆斯!

· 中国海军和平方舟离开塞拉利昂前往加蓬

· 其实混合动力车还有另一种玩法

· 宝马全新X3将明年上市 官方确认不加长

· 虽败犹荣!国象世界杯丁立人加赛憾负获亚军

· 中国酸奶销售额将超纯牛奶

· 虞兮虞兮奈若何,森林之风——虞姬

· 幻想图录:苍穹浩瀚 繁星若尘 高清星空壁纸(11)

· 繁思折风景摄影作品系列三十九(十五道沟的水)

· 天津,中国旅游最值得去的地方

· 资讯盘点向,打破次元,原来国漫已经这么厉害了么!

· 美团的“防守”:办公室无人值守货架打开的“另一扇门”

· 捡垃圾将成首富,“环保巡查+灭燃扶电”其实是天使投资!

· 董明珠刘强东强强联手,打造智能冰箱,我的电器我做主

· 柏林警察总局遭不明身份者潜入:多枚勋章被盗 幸好武器没丢

· 2017暴雪礼包全手办一览:D.Va脸崩了,法拉身披合金皮肤

· 曼谷菜市场的血蛤、生蚝10元一份、贻贝6元一袋,哪款您最爱?

· 郭富城宝宝是女儿,坦言亲手剪脐带紧张的发抖,黏女儿不愿出门!

· 12万提比亚迪宋MAX,每月6G流量,不输特斯拉中控屏能打王者荣耀

· 迪拜又进阶了!豪车变警车,劳斯莱斯、兰博基尼像计程车一样普遍

· 临近中秋,一大波新鲜海货来袭,准备好你的钱包,尽情采购吧

· 在广州增城二龙山发现猴耳环(尿桶公)

· 韩国经济在陷泥潭:中国大幅抄底韩国

· 2018俄罗斯世界杯购票指南

· 来来来,见面分一半——三国杀高嘲讽武将——游戏可以输,大师必须死

· 简简单单的款式,没有过多复杂的装饰的上衣,怎么看都觉得喜欢

· 走一趟莫斯科的“王府井大街“去看普希金,游红场必吃古姆冰激凌

· 骑士欲送走TT换小乔丹组超级五巨头,这下勇士和雷霆都别玩了

· “最差电影”《纯洁心灵》导演:撤档因网络暴力,肯定会再上映

· “老干部”靳东人设崩塌,莫非是因为它……

· 大帝李毅:那要是赶到现在,我绝对可以多踢两年

· 对不起,我要去宜兴了

· 奔驰靠这款汽车享誉世界,成为各国元首礼宾车,还抢了美国车的饭碗!

· 风景图集——日本第一高峰:富士山

· 江苏卫视10部待播大剧 有4部她是女一 网友:她被江苏卫视承包了

· 一身红装,如花似玉,倾城

· 邱毅:赖清德是“投机台独” 大陆“兵临城下”就会投降屈服

· 那一天,中国有三个首富

· 儿子极不孝顺,老人生气进城当保姆,一不留神,成了别人家的妈妈

· 车企举办公益活动有新思路:不再量化公益活动的成果

· 收购?别开玩笑了,长城才看不上一堆烂摊子,但是市场份额是关键

· 民国时出宝最集中的一次盗墓:挖了13座古墓,仅青铜鼎就盗出28只

· 佛家是看命最精准的一门,为何从来不替别人算命?

· 喝凉白开会致癌吗 喝凉白开等于慢性自杀是真的吗

· 小时候爸妈给的零花钱,全都买些这东西,长大后见它们酸酸甜甜的

· 美景图集:曲院风荷景色

· 连阴雨后的西安居然出现了如此美的火烧云

· 最喜欢烤肉在嘴里爆汁的感觉,你带着我,我带着钱咱一起去吃肉去

· 商洛凤冠山之游,栩栩如生,引人入胜,值得一游

· 河南老家早上喝的几碗汤 看着就想家

· 简简单单用铅笔就能画出这般不可思议的画作出来

· 奇幻摄影:月光猎人,石林洞穴和箭!

· 现代中式实木书桌,传承古国遗风、广大华夏美德

· 成都名片你知道哪些?除了宽窄巷子和锦里还有东郊记忆!

· 放学后的时光

· 湖南举行丁酉年“祭祀炎帝陵”典礼

· 全国总工会召开民生新闻专题发布会

· 虽然他是张学友,但是如果要比演技,我们差他一个影帝

· 这几部在谍战剧中比较强的谍战剧 当初你看过吗?

· 我为什么偏爱银行股

· 英首相特蕾莎·梅会见欧洲理事会主席图斯克 双方贴面问候

· 比韩信还会偷水晶?王者荣耀新英雄苏烈的原型居然这么猥琐?

· LOL:S7半决赛门票被翻3倍,大麦网因此上了热搜

· 海南买房养老哪里最靠谱 万宁兴隆给你满意答案

· 深爱,无声

· 你打开它,才知道是做这个的

· 大片来袭 有一种超跑叫爆改GK5

· 看看盘锦的金秋河蟹市场是如此火爆一箱箱河蟹24小时顺风快递到家

· 马云砸1000亿菜鸟总裁信心爆棚:5年内全面取胜!

· 微软两任掌门人都不懂量子计算依然坚定

· 2016款1.6自动舒适版POLO 改装记

· 毕马威给券商支招:从财富管理模式创新到Fintech……各种新套路

· 洪水来了一声吼,中国军人抗洪抢险最美的瞬间

· 加拿大C-6法案给留学生的最大福利

· 古史今说:唐倭战争前,日本网议对南朝鲜多次插足!(第473期)

· 一家6人中毒紧急入院抢救,家家都吃的它竟比河豚还要毒100倍!

· 全家团聚变生死离别 一家老小8人烧伤老人去世 治疗已花费数百万

· 农村大姐用这种方法做柿子干,自然晒制,味甜而不腻

· 生意火爆的北五环新宠儿 都是为了这瓶鹤顶红?

· 徒步旅行日志第170天,连跨两座大桥抵达福州长乐市

· 德甲领头羊欧冠仅两场便已出线渺茫,顾头失尾恐难成大器

· 小马云正式进军娱乐圈 百万豪车接送出演电视剧

· 要买车的抓紧!汽车购置税2018年将恢复10%的税率,几千块又没了

· 古特雷斯呼吁国际社会共同努力消除核武器威胁

· 9月26日一分钟阅尽天下军情

· 《英雄联盟》送OMG战队主题月饼 为纪念S7总决赛

· 适合三家之口的小菜,好吃简单,米饭一会就见底了

· 总裁的蜜制娇妻

· 西安城墙雨中行——厚重 沧桑 壮观

· 全国27所拥有毛主席雕像的高校,有你的母校吗

· 平常要经常吃这个菜,比肉好吃,还非常有营养,十分钟就能做好

· 9月26日,饲料行业一匹黑马脱颖而出!它用6年时间跻身A股主板!

· 小米苹果汗颜 安全双芯片+超清全面屏金立M7现货开售

· 巅峰时期单换詹姆斯的存在,让我们来回顾魔兽巅峰时期十大战役吧

· 意大利人是罗马后裔,装备也不错,为何战斗力那么低?

· 汽车图集:传祺-GS5 Super

· NBA最疯狂的一个夏天没有之一!短短3个月,9支球队更换了老大!

· nba球星戴墨镜谁最有范?韦德潮骚,加内特安东尼皮尔斯黑帮气质

· 菌菇鱼头汤

· 以后不需要豪车了,10万元买辆房车,车子房子一次搞定!

· 中国女排名将魏秋月生日晒结婚证 与女排陪打帅哥喜结连理

· 华女持绿卡入美 每次都被关进小黑屋审查!只因她少做一件事 警惕

· cf手游,9.29狙神争霸版本提前看!

· 汕头纪行——别具特色的大峰庙

· 你为什么总是降不好高血压,医生告诉你别怱略了这3点好方法!

· 繁思折风景摄影作品系列四十八(海螺沟)

· 3元一个5元两个,好吃不贵还能美容养颜,很多人都爱吃卖的人却少

· 致敬消防官兵,爱画少儿美术培训中心消防绘画巡展二欢迎点赞评论

· 犹太人为何对中国有特殊感情?二战时犹太人在华生活照给了答案

· 韩国的美女是真的多

· 邯郸武安又添一处新景区,好山好水好风光!

· 国务院:健全质量安全快速反应 扩大召回商品范围

· 超过1年时限,劳动者能否认定工伤?

· 悼念九世王最后时限延期5天

· 奥迪A6L,纠结过后的乞丐王子

· [赛前群访] GK:已经制定好应对仙阁的战术

· 斗鱼阿冷送粉丝限量版月饼,暗中宣示自己人脉广?

· 说说你手机里那些很帅的陌生人?!

· 我就是那个独自旅行的女孩子,一个人的自由与疯狂

· 极致的日本寿司,让你感觉活鱼在胃里扑腾

· 教你如何通过内裤看是否患有妇科疾病

· 野外观鸟:北灰鹟,擅长在空中捕食蚊虫

· 山西男篮走进校园 斯科拉、詹宁斯遭万人围堵索要合影

· 服务长江经济带“钢腰” 光大银行落户古城荆州

· 《琅琊榜2》新出预告片,网友可以放心了,黄晓明并不是男一号!

· 独访|京东无人机刘艳光:从破局者到引领者

· Model X 60D 提车一周有感

· 党史日历丨9月27日

· 风景图集——人们亲切地称它为“生命之湖”:琵琶湖

· 繁思折风景摄影作品系列五十二(风情上海滩)

· 房子多卖了万元 中介为求早日“落袋”扣下卖家他项权证

· 盘点进入中国影视界的甘肃美景

· 东西部实力有多悬殊?数据暴露出差距,得分榜前30西部占67%!

· 赵大鹏、任骏威等6名球员暂未通过CBA体测

精彩图片