获取人物坐标,对控制人物事件有着重要的作用(续)

找猫的老鼠   2017-07-04 08:17

前言:对于昨天发的文章在此我深表歉意,由于昨天时间比较张没有来的及给大家解释,所以今天特意来详细讲解一下。

第一步:今天用的是天使插件(设计:一个组合框,5个按钮,前期的工作还是要绑定窗口的,大家先看一下设计窗口)

获取人物坐标,对控制人物事件有着重要的作用(续)

设计窗口

第二步:咱们来看一下绑定窗口事件(这里绑定窗口主要用到了 进程数量 = 进程_枚举 (进程名数组, 进程ID数组) 要 计次循环首 (进程数量, i) 把要用的窗口绑定到 组合框里面,具体看下面图片和代码)

获取人物坐标,对控制人物事件有着重要的作用(续)

寻找窗口1

获取人物坐标,对控制人物事件有着重要的作用(续)

子程序(寻找窗口)

第三步:我们看一下怎么样绑定窗口(用到的是这个:BindWindow (Hwnd, “gdi”, “windows”, “windows”, 101) 不了解的大家可以百度一下)

获取人物坐标,对控制人物事件有着重要的作用(续)

窗口绑定

获取人物坐标,对控制人物事件有着重要的作用(续)

暂停,恢复,结束脚本

第四步:我们来看一下怎么获取人物坐标 这个我用到了找色 TS.FindColor (280, 121, 741, 437, “ff003”, 0.9, 4, ZX, ZY) 解释:280, 121, 741, 437 人物周边的坐标,可以用大漠工具抓图找到, “ff003”这个是血量的颜色,0.9是相似值相对于血量的颜色值来说的,ZX,ZY是变体型。来具体看一下代码:

获取人物坐标,对控制人物事件有着重要的作用(续)

人物坐标

具体代码如下:

.版本 2

.支持库 xplib

.支持库 spec

.支持库 EThread

.程序集 窗口程序集1

.程序集变量 TS, 类_天使

.程序集变量 窗口数组, 整数型, , "0"

.程序集变量 许可证, 线程许可证

.程序集变量 Hwnd, 整数型

.程序集变量 线程句柄, 整数型

.程序集变量 i, 整数型

.程序集变量 k, 整数型

.子程序 __启动窗口_创建完毕

.局部变量 返回值, 整数型

XP风格 (1)

寻找窗口 (“Game.dat”)

返回值 = TS.SetPath (取运行目录 ())

调试输出 (“设置全局录制返回值:”, 返回值)

.子程序 寻找窗口

.参数 进程名, 文本型

.局部变量 进程名数组, 文本型, , "0"

.局部变量 进程ID数组, 整数型, , "0"

.局部变量 进程数量, 整数型

.局部变量 i, 整数型

进程数量 = 进程_枚举 (进程名数组, 进程ID数组)

.计次循环首 (进程数量, i)

.如果真 (进程名数组 [i] = 进程名)

加入成员 (窗口数组, 进程_ID取窗口句柄 (进程ID数组 [i]))

.如果真结束

处理事件 ()

.计次循环尾 ()

.如果真 (取数组成员数 (窗口数组) > 0)

.计次循环首 (取数组成员数 (窗口数组), i)

组合框1.加入项目 (“第” + 到文本 (i) + “窗口,标题:” + 窗口_取标题 (窗口数组 [i]), )

.计次循环尾 ()

组合框1.现行选中项 = 0

.如果真结束

.子程序 _按钮1_被单击

.局部变量 绑定值, 整数型

Hwnd = 窗口数组 [组合框1.现行选中项 + 1]

绑定值 = TS.BindWindow (Hwnd, “gdi”, “windows”, “windows”, 101)

调试输出 (“窗口绑定返回值:”, 绑定值)

.如果 (绑定值 = 1)

许可证 = 线程_创建许可证 ()

线程句柄 = 线程_启动 (&多线程, , )

.否则

信息框 (“窗口绑定失败”, 0, )

.如果结束

.子程序 _按钮2_被单击

.如果真 (线程句柄 > 0)

线程_挂起 (线程句柄)

.如果真结束

.子程序 _按钮3_被单击

.如果 (线程句柄 > 0)

线程_恢复 (线程句柄)

.否则

.如果结束

.子程序 _按钮4_被单击

.局部变量 返回值, 整数型

.如果真 (线程句柄 > 0)

返回值 = TS.UnBindWindow ()

调试输出 (“窗口解除绑定返回值:”, 返回值)

线程_退出许可区 (许可证)

线程_删除许可证 (许可证)

强制结束线程 (线程句柄)

.如果真结束

.子程序 多线程

.局部变量 ZX, 变体型

.局部变量 ZY, 变体型

.局部变量 序号, 整数型

线程_进入许可区 (许可证)

.计次循环首 (100, k)

序号 = TS.FindColor (280, 121, 741, 437, “ff003”, 0.9, 4, ZX, ZY)

调试输出 (“人物坐标返回值:”, 序号)

.如果真 (序号 > -1)

程序_延时 (100)

调试输出 (“人物坐标:”, ZX.取数值 (), “/”, ZY.取数值 ())

跳出循环 ()

.如果真结束

.计次循环尾 ()

' 首先 确定人物坐标

.子程序 _按钮5_被单击

' TS.Capture (0, 0, 1024, 768, “测试.bmp”)

谢谢大家留言互粉!

内容推荐
更多阅读

· 最“奇葩”公司:领导没有办公室,没有地位,却年入2.6亿!

· 微软推出轻量级系统Windows 10 S,它究竟有何不同?

· 特斯拉市值比肩通用汽车,原因在这

· 上高速过站拿卡扣2分、罚款两百,这些违章陷阱,你有没有中招

· 印度驱逐舰宣称远超中国052D,连技术都是买来的何来勇气叫板

· 这是一只有金刚狼一样的骨刺,吃起来要扒皮的怪鱼:扒皮狼

· 国外网友看了惊得半天说不出话:生死就在这一秒间!

· 日媒称中国海警船连续6天在钓鱼岛附近海域巡航

· 数据显示,垂直 SaaS 公司拥有更高的估值|投资人说

· 骄傲!世界最炫酷的家庭气象设备卖遍全美 由中国团队打造!

· 海信董事长周厚健:“利他”才能“利己” 激发技术创新

· Q1手机战报:华为猛增重夺第一 苹果最惨 小米表现大跌眼镜

· 让iPhone裸机双卡黑科技 京东众筹已经大功告成

· 谁是第一家10000亿市值的公司!腾讯和阿里巴巴都没戏?

· 人们为什么会持续购买苹果产品

· 这条光纤不需转换器也能实现“电-光-电”转换

· 成绩单靓丽!佛山上市家电企业绩优利厚

· 曝奔驰AMG GT假想图 定位四门轿跑/或命名GT4

· 2017一季度轿车排行榜,帝豪强势进入前十

· 中通:破双百亿只是开场,“一优多强”好戏在后面

· 车辆工程:我们真的不是“修车”的

· 兰博基尼最自私的跑车价值1.2亿

· 遵义汽贸城开园,香车美女云集,点燃夏日激情!

· 用面包车的车标还想骗妹子,美女一秒识破,扭头就走

· 大婚当天废了三辆奔驰S级

· 四川有一辆车,开了100多年了,全世界就这一辆

· 奔驰GLE增新版本 售价大降/油耗不足3升

· 全球仅三辆的兰博基尼的毒药停在小巷里,邻居:这车子要一千万吧

· “大飞机之路”上我们究竟经历了什么?

· 俄媒:基辛格与布热津斯基力主美俄缓和

· 吕布裸破军到底如何?什么样的局面可以裸破军开场?

· 曹操,曹操,你究竟冤杀了多少好人

· 在甘肃陇西,城里人的一天是从一碗热气腾腾的担担面开始的!

· 这车比亚迪F3还强一点、高配便宜一万!

· 中国东北发现新型有羽恐龙化石 体态特征似鸟类

· 共享单车之后,共享篮球也来了

· 没想到:显卡市场原来如此凄凉!

· 实习生月薪7100美元,微软是怎么做到的?

· 只因马云的支付宝 日本人担心被中国看不起

· 16nm加持,华为再发Nova二代怼OV

· 公交卡是如何出卖你的!

· 择天记的广告植入太强大,来看那些古装剧的广告植入你不得不服

· 大众公司全球62万员工都将配备苹果iPhone

· 库克自曝苹果将发3款产品,已2年未更新,完全重做

· 尊重传统:iOS 10.3修正西班牙海鲜饭Emoji图标

· 飞出新高度!持有八年,这枚域名让他豪赚近800万

· 宝马全新X4谍照首曝光 颜值高

· 豪华品牌SUV不到30万就能买到?外形,动力,大空间全都有!

· 自动挡汽车下坡可挂空挡吗?

· 可抢韩系份额 雪铁龙天逸或售16.58万起

· 汽车级别划分 你真的都懂吗?

· 新一代宝马1系掀背2018年上市 不再搭载六缸机

· 平民赛车系列之——小巧灵活雨燕赛车改装

· 老婆全力支持 天籁2.5L智享版带回家

· 多只“伪白马股”卸下面具 估值高企机构现分歧

· 皇帝巡幸有套路,明成祖却与众不同,喜欢带上很多犯罪分子

· 家门口早市,买俩羊头烀了吃

· 喜怀双胞胎,20周孕检时医生的话却让我哭了

· 黄河小北干流段控导工程面貌

· 传奇传说:强夺人妻,活该遭报

· 里程碑之夜法国跑车大伤离场 除却他圣城究竟路在何方

· 杜德利谈米尔斯的争议犯规:联盟应停止这种判罚

· 今年会是最后一次四六级考试?90后总被坑!表示不能接受!

· 教育部:将安全风险防控作为考核学校重要内容

· 这家会所IPO业务排名第一,但证监会3个立案调查未结,被采取12个监管措施,还被证监会处罚

· 惨烈的匈牙利包围战 1944

· 研究发现木星杀死了很多同胞兄弟

· 阴阳眼看到鬼作怪:(蒸馒头不长大、水烧不开、晚上睡不着!)

· 美总统“末日客机”内景曝光 特殊装备应对核战

· 乌云压顶!电闪雷鸣!8级大风!今早深圳多少上班族哀嚎“湿身”……

· 张翰为古力娜扎甜蜜庆生,万万没想到郑爽却做了这样一件事!

· 女人看起来老不老,取决于这条你不曾留意的线

· 《塞尔达传说:荒野之息》汉化工作量巨大,模拟器1.76将更新

· 载人航天竞争,让各国眼红的“月球大宝藏”

· 套路深!买车容易,维护贵的6款中大型SUV

· 手机正在毁灭我们?

· 北京河北等5省份PM10爆表 这次沙尘为何不按套路出牌

· 这群人专职在武汉坐公交:盯紧可疑人员 收缴危险品

· 东京中心竟深藏美军基地?!美军机随意穿行惹众怒

· 法媒:利比里亚神秘“怪病”迅速蔓延 已致12人死亡

· 这款suv价位8万多,省油是亮点,但上陡坡起步直冒冷汗

· 三国:苍天何曾绕过谁,试看三国演义中的天道轮回

· 蒂勒森强调美国不寻求朝鲜政权更迭

· 舒畅:出道26年“0”绯闻,说她不火?那是没经历过那年代!

· 天河二号计算一百年,它用不到一秒钟,世界首台量子超算中国问世

· 老公带我去吃米其林餐厅,一不小心花了4000块,婆婆骂我败家

· 18岁天天吃红烧肉,剧烈腹痛到医院,医生说胆没用了!

· 小伙男扮女装拿下选美冠军!主办方获悉真相气得追回奖金!

· 泾阳检察:酒店保安监守自盗 网络丢失登记显贼踪

· 中山一新婚男子撞灯柱身亡 妻子将要生了

· 足协杯对阵:京沪大战恒大华夏死磕 权健上港富力战弱旅

· 日本欲牵头挽救TPP抗衡中国 外媒:中国已掌握主动

· 30名印度渔民涉嫌非法捕鱼遭巴基斯坦海事安全局逮捕

· 《花少3》同款贵到惊人!娜扎每套穿搭超2万,怪不得江疏影都要抢

· 如何做DotA2的“毒瘤”?从改变开局商店开始!(误

· 关于质子的三个谜题

· 癌症病人哪些东西不能吃?保健品真有大威力?吃什么会恶化?

· 葡萄拉花应该怎么做(附详解)

· 北方汽车坟场之货车篇

· 这家跨境支付公司对汇差利润点说不,拿下腾讯、红杉数千万融资

· 媳妇在家干农活,我也就放心在外面干工地了

· 《外科》钟主任去世被虐哭了,杨新鸣与靳东合作两部戏下场都不好

· 看过马刺GDP的现任妻子之后,科比不淡定了

· 神似BABY的俄罗斯超模,五官完美身材完胜

· 不幸生在帝王家 明清王爷生活很悲催

· 读得出明媚,却不滞涩 就如醇醇的红酒,香醇而又浓郁

· 锡纸冒脑花 锡纸烤豆腐 锡纸烤鸡蛋糕 烤生蚝 烤羊腿 烤羊排

· 天津卫讲究吃货,这40道题至少得答出3道来?不服来战!

· 直击:无法动弹的90后袖珍人

· 中国移动日租卡,15G流量,不用不收费,最低仅收8元月租费!

· 宁述勇曹志刚火线加盟 只是为了给观致续一秒吗?

· 连斩三名围棋世界冠军 太原小伙赵晨宇“火”了

· 每到1号出账单 就好想找个人继承我的蚂蚁花呗

· 依阿华身上的东西 美国人居然最喜欢这个?!

· 揭密:雍正为何除掉登基大功臣年羹尧?

· 扑朔迷离的怪物谜团——尼斯湖水怪

· 如果一颗 恒星变得如此之大,以至光线也不能逃离,将会发生什么

· 初中是孩子成绩的“突变期”!家长做好这3件事,孩子稳居第一!

· 心烦易怒,试试2000年前的小处方,只有2味中药

· 懒兔子医案:如何用金匮肾气丸治好多年湿疹?

· 十年同学再聚首,未料春心荡漾生

· 没有假设!6G+后双摄1300万+骁龙,这次是真的

· 河北原邯郸县委书记何志刚落马,曾获“全国优秀县委书记”

· PM2.5爆表,雾霾来临,一篇文章教你如何安全驾车!

· 考驾照科目一必须要会的15道题,你能都做对吗?

· “襄面女皇”程艳阳 勤奋书写传奇人生

· 盘点遂宁特色鱼馆,爱吃鱼的你一定不能错过!

· 一堆熟肉丢在脏水池里!这样的沙县小吃你还爱么?坐标赣州赞贤路

· 婴儿大运动、精细运动、语言、社交行为每个月的发育水平

· 欧洲童话——羊角村,这个小镇700多年来,不买汽车,不修公路

· 1.6T涡轮增压,215时速,23万,还选择CRV就不明智了

· 我也是第一次见,居然还有这么便宜的新车

· 这款suv裸车价格9万元,每一处都是优点,车子也不咋费油

· 假如人类进入太空之后死亡,那么接下来会发生什么现象?

· 这难道就是传说中的比亚迪“汉”跑车的造型吗?是学生设计的!

· 世界最大美女聚集地竟然紧临我国,但是娶她们的大部分是中国民工

· 最高人民法院“失信被执行人名单”披露 78家东莞失信企业上黑榜

· 不愧是特里的好搭档!38岁欧洲杯冠军老将用实力展现教科书防守

· 北美TSM艰难战胜外卡:让二追三险些被爆冷!

· 富家女花336万买金标奔驰迈巴赫S600:原来美女也是汽车迷

· 浙江土豪迎亲竟用清一色货车车队,路虎做摄像车这场面壮观喜感

· 建国以来中国女性发型变迁史

· 马拉松世界纪录破2究竟离我们有多远最新世界十佳马拉松记录出炉

· 解读:为什么中方同菲律宾就朝鲜半岛局势交换看法

· 你没有看错:大厅摆架钢琴的竟是家医院,演奏者还是医生

· 陈冠希被毁,是太过于敢作敢当还是本人应得?

· 《三国志》记载有误,关羽后代已找到,族谱是国家文物,要求上交

· 红尘人像摄影——往事下酒,回忆宿醉

· 顺产生孩子,没想到遇到前男友,更尴尬的是他居然是我的……

· 车长近6米 宽1.99米 重量2.7吨 罕见的右舵车型

· 泰国街头捕获野生暴龙,太可怕吓到我都闪尿啦

· 3款最好的中大型豪华SUV,每款都是撩妹神器!你值得拥有!

· 俄罗斯美女找中国男人的理由:让人脸红

· 深圳老板提车奔驰新E级发朋友圈,生意伙伴都以为我买了S级

· 快手网红开什么车?来看看快手网红们的豪车!

· 80后作家从穷小子变上海滩富豪,三栋数亿洋楼,出行座驾更霸气

· 美华裔男子连砍妻子32刀 陪审团裁决其谋杀罪名成立

· 外观更时尚 江淮瑞风S2尚酷版正式上市

· 摩纳哥一招失手导致主场兵败尤文,阿莱格里简直可怕

· 太极拳界三大怪,或许是太极拳名誉被砸的根本

· 人类飞船要达到其他星系只要69年

· 大扬州“网红美食”一条街,13家口碑爆表店,够你吃半个月!

· 内含180种营养的蜂蜜在遇到它之后,火力全开,各种疾病轻松治

· 30句写给自己的话,励志语录签名

· 故事:花季少年缘何举刀弑母,母亲的QQ聊天记录揭开真相

· 曝斯柯达VISION E皮卡假想图 量产无望

· 7款中型SUV对比 为颜值Ta做了哪些手脚?

· 揭秘“二二一”:高原上的中国第一个核武器研制基地

· 外星人从不回答

· 百公里提速只需9秒 车主首谈上汽通用雪佛兰迈锐宝XL

· 国产大飞机C919首任机长:备战首飞 信心满满

· 伊朗煤矿爆炸事故已致35人丧生 80余人仍被困

· 冯小刚《芳华》预告片66字137秒泄露男一号黄轩两大秘密

· 从神车普锐斯看出中国人的精明!不是我们不识货而是……

· 国内人均奶酪消费仅为日韩的1/50,提高人均固体乳制品消费量

· 曾请舒淇代言,遭遇高层地震,低调复苏:这家酒庄5年生死时速

· 农村集市上的灵宝脂油烧饼,2块一个,老夫妇一天能卖400个

· 汽车图集:兰博基尼 Aventador LP700-4

· 2018 阿斯顿马丁VANQUISH S,激情永远不变

· 南京一配餐企业疑涉用霉变食材为小学生供餐,被勒令停业整顿

· 昨晚瓦基弗银行全队飞日本备战世俱杯 向今年第二冠发起冲击

· 原创:二十世纪四十年代至今潜艇类电影汇总

· Facebook再雇3000人检查暴力内容

· 福州的这些藏匿在各个角落的美食小店,里面竟是难以置信的热闹!

· 很多人喜欢吃黄瓜,但大部分人不知道吃黄瓜竟然有这么多好处!

· 90后小伙买艾瑞泽7半年后,总体感觉不错,但有一点不是很满意

· 风清扬从哪学的独孤九剑?背后是否有不可告人秘密?

· 我来吐槽一下我妻子家的奇葩亲戚

· iOS 11或新增“Automator”应用 WWDC发布

· 天马轴承集团股份有限公司关于预计2017年度日常关联交易的补充公告

· 朝媒谴责萨德:韩国是最大受害者 迟早遭核浩劫

· 徐晓冬为何招人恨,看看八卦掌董海川和太极拳杨露禅怎么约架

· 大唐高祖李渊的成长

· 湘潭这家店的鸭子味道销魂,吃了还想吃!

· 夏钓,你不得不知的七句钓谚!

· 老美评选操控好的6款四驱SUV

· 两连击!中澳两国数据不理想,施压澳元跌至四个月低位

· 传统零售为什么必须重构?

· 记忆中的味道:淮北人走到哪儿都不会忘记的美食

· 出现这3个症状赶紧去医院别犹豫,血管已经完全堵塞了!

精彩图片