获取人物坐标,对控制人物事件有着重要的作用(续)

找猫的老鼠   2017-07-04 08:17

前言:对于昨天发的文章在此我深表歉意,由于昨天时间比较张没有来的及给大家解释,所以今天特意来详细讲解一下。

第一步:今天用的是天使插件(设计:一个组合框,5个按钮,前期的工作还是要绑定窗口的,大家先看一下设计窗口)

获取人物坐标,对控制人物事件有着重要的作用(续)

设计窗口

第二步:咱们来看一下绑定窗口事件(这里绑定窗口主要用到了 进程数量 = 进程_枚举 (进程名数组, 进程ID数组) 要 计次循环首 (进程数量, i) 把要用的窗口绑定到 组合框里面,具体看下面图片和代码)

获取人物坐标,对控制人物事件有着重要的作用(续)

寻找窗口1

获取人物坐标,对控制人物事件有着重要的作用(续)

子程序(寻找窗口)

第三步:我们看一下怎么样绑定窗口(用到的是这个:BindWindow (Hwnd, “gdi”, “windows”, “windows”, 101) 不了解的大家可以百度一下)

获取人物坐标,对控制人物事件有着重要的作用(续)

窗口绑定

获取人物坐标,对控制人物事件有着重要的作用(续)

暂停,恢复,结束脚本

第四步:我们来看一下怎么获取人物坐标 这个我用到了找色 TS.FindColor (280, 121, 741, 437, “ff003”, 0.9, 4, ZX, ZY) 解释:280, 121, 741, 437 人物周边的坐标,可以用大漠工具抓图找到, “ff003”这个是血量的颜色,0.9是相似值相对于血量的颜色值来说的,ZX,ZY是变体型。来具体看一下代码:

获取人物坐标,对控制人物事件有着重要的作用(续)

人物坐标

具体代码如下:

.版本 2

.支持库 xplib

.支持库 spec

.支持库 EThread

.程序集 窗口程序集1

.程序集变量 TS, 类_天使

.程序集变量 窗口数组, 整数型, , "0"

.程序集变量 许可证, 线程许可证

.程序集变量 Hwnd, 整数型

.程序集变量 线程句柄, 整数型

.程序集变量 i, 整数型

.程序集变量 k, 整数型

.子程序 __启动窗口_创建完毕

.局部变量 返回值, 整数型

XP风格 (1)

寻找窗口 (“Game.dat”)

返回值 = TS.SetPath (取运行目录 ())

调试输出 (“设置全局录制返回值:”, 返回值)

.子程序 寻找窗口

.参数 进程名, 文本型

.局部变量 进程名数组, 文本型, , "0"

.局部变量 进程ID数组, 整数型, , "0"

.局部变量 进程数量, 整数型

.局部变量 i, 整数型

进程数量 = 进程_枚举 (进程名数组, 进程ID数组)

.计次循环首 (进程数量, i)

.如果真 (进程名数组 [i] = 进程名)

加入成员 (窗口数组, 进程_ID取窗口句柄 (进程ID数组 [i]))

.如果真结束

处理事件 ()

.计次循环尾 ()

.如果真 (取数组成员数 (窗口数组) > 0)

.计次循环首 (取数组成员数 (窗口数组), i)

组合框1.加入项目 (“第” + 到文本 (i) + “窗口,标题:” + 窗口_取标题 (窗口数组 [i]), )

.计次循环尾 ()

组合框1.现行选中项 = 0

.如果真结束

.子程序 _按钮1_被单击

.局部变量 绑定值, 整数型

Hwnd = 窗口数组 [组合框1.现行选中项 + 1]

绑定值 = TS.BindWindow (Hwnd, “gdi”, “windows”, “windows”, 101)

调试输出 (“窗口绑定返回值:”, 绑定值)

.如果 (绑定值 = 1)

许可证 = 线程_创建许可证 ()

线程句柄 = 线程_启动 (&多线程, , )

.否则

信息框 (“窗口绑定失败”, 0, )

.如果结束

.子程序 _按钮2_被单击

.如果真 (线程句柄 > 0)

线程_挂起 (线程句柄)

.如果真结束

.子程序 _按钮3_被单击

.如果 (线程句柄 > 0)

线程_恢复 (线程句柄)

.否则

.如果结束

.子程序 _按钮4_被单击

.局部变量 返回值, 整数型

.如果真 (线程句柄 > 0)

返回值 = TS.UnBindWindow ()

调试输出 (“窗口解除绑定返回值:”, 返回值)

线程_退出许可区 (许可证)

线程_删除许可证 (许可证)

强制结束线程 (线程句柄)

.如果真结束

.子程序 多线程

.局部变量 ZX, 变体型

.局部变量 ZY, 变体型

.局部变量 序号, 整数型

线程_进入许可区 (许可证)

.计次循环首 (100, k)

序号 = TS.FindColor (280, 121, 741, 437, “ff003”, 0.9, 4, ZX, ZY)

调试输出 (“人物坐标返回值:”, 序号)

.如果真 (序号 > -1)

程序_延时 (100)

调试输出 (“人物坐标:”, ZX.取数值 (), “/”, ZY.取数值 ())

跳出循环 ()

.如果真结束

.计次循环尾 ()

' 首先 确定人物坐标

.子程序 _按钮5_被单击

' TS.Capture (0, 0, 1024, 768, “测试.bmp”)

谢谢大家留言互粉!

内容推荐
更多阅读

· 安居某工地基础桩尖的焊接,筏板垫层的施工

· 心肌梗死三天后才来到医院

· 美国拉斯维加斯校车与小汽车相撞 致1死16名学生受伤

· 专偷集体宿舍小偷落网 称这些地方很少锁门容易下手

· 做好这三点,帮孩子搭建一个强大的免疫系统

· 4缸发动机时代,你还记得昙花一现的5缸发动机吗?

· 马克龙VS勒庞:终极对战一触即发 谁将赢得这场世纪大选?

· 今日立夏,全家这样做,保你一年心脏健康!

· 麦长青离开TVB半年又回巢

· 郑州荥阳:万山之巅望四周,四月春光一镜收

· 专访:C919不仅仅是中国的骄傲

· 银河护卫队2全解析,5个彩蛋全在这了!

· 美国出动6个航母战斗群70万人参战,赢得该地区20多年主导权

· 广州四大行首套房贷上调至基准利率 百万房贷20年成本增近10万

· 天津航空一航班延误,乘客讨说法被强行带下机

· 笔触细腻画风冷艳高贵让人过目不忘 匪萌十月笔下的冷艳 少女

· “舞”动中国,无处不在,河南尬舞、北京水兵舞最为辣眼睛

· 165款客车获1.2倍补贴!钛酸锂电池雄起第4批推荐目录分析

· 夜忆往事:那黑暗的一年,是这五大忠臣将尤文拉出深渊!

· 都是古天乐最爱的人,前任和现任相差4岁,命运大不同!

· 瑞为智能詹东晖:人脸识别打开智能店铺数据大门

· 湖南女子因3岁儿子吃饭慢将其打死,网友热传:谴责这位狠心妈妈

· 镜头下︰父母与孩子相同年纪的对比照,网友︰一模一样

· 老版《聊斋》被删的两段《水莽草》和《凤阳士人》讲述何事?

· 特斯拉绕不过亏损难题 马斯克表示“年底明确中国生产计划”

· 18款大方的客厅吊顶设计

· 托蒂的10号球衣该退役吗?看看其他队咋做的!

· 王思聪为看陈欧白花三个亿创业,发话直播吃翔,原来俩人早有过节

· 低价游猫腻多!记者体验180元低价团:上车就加钱

· 2017目标20万人!房价高企态势下,西安拿啥吸引大学生落户?

· 某预备役高炮团7昼夜历经23个实战化课目考验

· 6句很暖心的话(给你心的温度)

· 山丹人自己造的成语,你懂了几个?

· 水墨江南——春水碧于天,画船听雨眠

· 人像外拍:她是个很自信的女孩

· 90年代澳门赌场罕见实拍照

· 新兴车企又一搅局者?威马AG2020概念车

· 正能量:37岁残疾男子的“自学”路

· 防不胜防!2017第一季度全球新增75万安卓病毒

· 中国足球“伤仲永”,陈涛亲诉天才陨落“谁之过”

· 伊斯科续约皇马只待官宣 回顾欧洲金童赛季高光时刻

· 美众议院通过对朝新制裁法案 外媒:旨在全方位切断资金链

· 安全帽有没有救过你的命?这些戴了安全帽的人太幸运了

· 美媒称中国富豪购买私人飞机不为炫富:便于开展海外交易

· 对IPO公司限售股解禁需未雨绸缪

· 激光武器离实战应用有多远

· 景甜、杨幂、唐嫣,谁的身材最好?3D开扒

· 卡扎菲的过度放纵,给自己的子女带来了什么

· 盘点日本那些日常小发明 第六个最奇葩

· 台军晒女兵操作机枪照挨轰:这样打完嘴唇会肿的像猪肝

· 捧红那么多人,琼瑶无助时只有两位退出娱乐圈的演员发声支持她

· 吻戏,赵又廷杨幂用力过度,黄晓明赵薇停不下来,最后一个最尴尬

· 特朗普开打税务战争:美国减税谁最担心?

· 阿勒泰地区开展警地森林灭火作战综合演练

· 社会办医正在迎来最好时机

· 为部队与军工厂搭一座桥梁

· 过分,拉齐奥球迷死亡威胁罗马球员!外国球迷就这素质?

· iPad依然没扶起来 苹果为什么还是不着急?

· 21世纪最佳防守球队:尤文仅排名第二,曼联才是第一!

· 天津航空产业助力国产大飞机起航

· 王者荣耀:五月五日开黑节,小编都打了一天了,你都经历了什么?

· 《情深深雨蒙蒙》5个细节暗藏玄机,可云孩子其实是陆司令的!

· 新生儿一天大便多少次才正常,母乳和奶粉喂养不一样

· 又一波机器人公司融资:钛米机器人获4千万元A轮融资;因诺航空获2500万元A轮融资|机器人日报

· 成龙大哥百亿资产确定分配计划 房祖名一生无忧

· 看360安全路由2斩获2017德国iF及德国红点工业设计大奖,不可忽视的设计细节

· 孙鹏杰教授广西艺术学院 授课

· 实拍正在拥吻中的情侣,上帝角度的欣赏,给人不一样的感受

· 《神话永恒》首日开140服 流水818万 将持续投放 长线运营

· 冠军热门实力评选:同是6连胜且巨头云集,勇士和骑士到底谁强?

· 省消防总队教育基地揭牌 常州“三杰”纪念馆在列

· 清华校长称赞:家庭最大的幸福,是有一位这样的妈妈!值得借鉴!

· 铁路爱好者

· 德国名宿:尤文是欧冠夺冠热门 苏宁是国米的大财富

· 韩媒称中国海淘韩货增幅因“萨德”放缓:仅去年同期一半

· 《灵魂摆渡》主演现状揭秘,他竟落魄到写信给节目组求上综艺!

· D姓男星八千万买卓伟手中出轨照,典韦达摩什么鬼?

· 西北工业大学团队为C919大飞机设计“翅膀”

· 图看真实的日本:实拍日本人的生活(1)

· 恐怖漫画:女生收到的提醒!

· 锤子手机被“狂热追捧”背后,为何销量一直惨淡?

· 肉得像团翔!强势盘点王者荣耀前期怂后期无敌存在的英雄

· 太监福利:每夜嫔妃侍寝竟首先被太监看光

· 门牙打飞、鼻梁肘歪、血溅赛场,绿军奇才的第四战还敢看吗?

· 英媒称特朗普在政治上玩火:越来越像正统共和党人

· 俄罗斯美女大妈来中国扫货包船往回拉,年收入十多万,最爱中国货

· 15岁出道,62岁凭《人民的名义》爆红,离异给前夫介绍工作

· 王者荣耀一个KOC头像框竟然卖1800,你会入手吗?

· 和你走过的每一个路口

· 镜头中的牡丹 国色天香 带给你视觉的盛宴

· 山东女子学院美女运动会

· 杨再兴和岳飞谁厉害 抗金名将杨再兴简介

· 自动驾驶上路测试,苹果入局汽车领域的这盘棋你看懂了多少?

· 无人与我立黄昏 后面的后面你知道么

· 我心德意志

· 访谈丨专访史蒂文斯 希望劳尔参加告别赛

· 从综艺海报看明星“番位”之争:排位可不是简单事儿

· 北京两将身价千万全运6场比赛仅17分 北京高层后悔逼走马布里

· 王者荣耀应该知道心得,不知道你就out了

· 一辈子很短,请为自己而活

· 特朗普首次出访选择沙特,想团结各宗教,却被国内政治拖了后腿

· 马云的又一场大颠覆!30年后医生失业、药厂消失?

· 山西三维集团股份有限公司关于召开2017年第三次临时股东大会的提示性公告

· 原油价格跌回减产前,OPEC和俄罗斯都心急如焚

· 申通快递股份有限公司关于公司股东股份补充质押的公告

· 专家:C919结构强度设计标准与波音、空客一致

· 11个发朋友圈的励志句子(落雨撑伞,风中请自己成长)

· 瓦茨克:没听说巴黎要买奥巴梅扬,只是媒体在说

· 故事:救了溺水少女,却被对方父母讹诈,躲藏多年,还是被找上门

· 带21.5吋触摸屏!围观美的新品智能冰箱

· 乒坛皇后身家千万为何嫁给大20岁的老头?生完孩子后她说出真相

· 中国十二大经济巨城,苏州深藏不露,青岛不可小觑

· 什么都舍不得的人,也不配拥有

· 流动性趋紧致近3000亿债券搁浅 债市沙尘暴

· 《蜗居》宋思明爱海藻?竟然因为她是“第一次”!

· 全球各地最能吃的人都在这里,中国最能吃的竟然是这么小的女生

· 不服来战:几张图就能证明你是否了解成都美食

· 拒绝巴萨首份续约合同 梅西嫌薪资不够?核心位置没保证?

· 又是一场活久见!解约的鹿晗和没解约的张艺兴竟然同台了!

· 孙悦叫板丁彦雨航!全运会最后名额即将出炉,山东出线希望大增!

· 又一阿根廷巨星来中超!曾是世界第一后腰的他 为防罗本拼到肛裂

· 王者荣耀:揭开国服最强称号的内幕,你也可以是国服最强!

· 七句金言,送给你

· 5日晚公告精选丨多家券商发布4月业绩

· 德罗赞竟废到这种程度!怂到球都不敢拿了?指望带伤洛瑞站出来?

· 活着活着就老了

· 让人心碎句子,爱恨扯平两不相欠

· 台湾新闻晚播报:民进党执政周年民怨四起

· 中国人保财险承保C919大飞机试飞险

· 郑州航展大考结束,地表最强战队齐聚五云山

· 若不被珍惜,又何苦维系

· 美到令人窒息的中式样板间设计

· 内蒙古兴业矿业股份有限公司关于高级管理人员增持公司股份的公告

· 杭州诺邦无纺股份有限公司关于举行2016年度现场业绩及现金分红说明会暨投资者接待日召开情况的公告

· 周海媚虽美却有个小缺点,你发现了吗?

· 台裔美军少校泄密只为贪色 哪知对方竟是FBI女特工

· 中航飞机股份有限公司公告

· 驴友穿越秦岭鳌太线失联后续:11人被安全转移下山

· 别建了,别存侥幸了,只能浪费个人财产!

· 妻子不管不顾,为了让6个孩子感受母爱,男子穿女装当妈10年

· 十句很不错的句子,送给想发朋友圈的你

· 中安消股份有限公司公告

· 故宫去厦门鼓浪屿开“分店”,哪些文物将首次面世?|政解

· 破格提拔的人,条件非常特殊

· 用人单位想单方调岗?别任性,须合法合理且必要!

· 中国第一男红娘,与小香玉两结两离,追求者为他整容给他巨款豪宅

· 5月6日-5月21日 湖州这些地方要停电

· 产妇被人撞伤,不能母乳喂养,肇事者该不该赔婴儿的奶粉钱?

· 超现实的句子(精辟)

· 演技越来越差的明星TOP5,是什么让他们变成现在这样?

· 买车就要买保值率高的车型 这款SUV或许是最好的选择

· 军营运动会,满屏尽是荷尔蒙

· 是什么帮你一夜7次无压力还不伤身?答案逆天了

· 不要为难自己,写的真好

· 夏天来了,来新疆旅游吧

· 气象台提醒:今天仍有四到六级阵风 外出需要防护

· 校园贷款毒害一批批大学生,陷入贷款漩涡无法抽身

· 2017最新征兵宣传片《中国力量》!

· 小儿脾胃调养随笔

· 一睡二抬三翻四撑五抓六坐七滚八爬九长牙十站十一扶周能走

· 因为爱你,所以离开你

· 山东高校 学生会干部携干事自习室浪漫表白

· 就是差距!NBA球星的非人尺寸,最后一图更让男网友羡慕妒忌

· 图赫尔:罗伊斯没必要去参加联合会杯

· 农民都不回农村种地了,对粮食价格会有影响吗?

· 八个句子,再爱的人还是会离开

· 泰森经纪人:接到了拉齐奥的电话,去意甲很合适

· 80余辆“连环燃烧” 蟹岛电动大巴燃爆之谜

· 律师法启动修订 律师能否向被告人核实人证?

· 中国平安一季度净利润稳增11.4% 互联网业务成综合金融引擎

· 中国两栖攻击舰正在建造,但舰载机方面有些尴尬

· 这骑自行车的鞋,贵的要2000多元!

· 连小保姆都是一级演员,他却只是三级演员,他们的身份太意外了!

· 分差无论是20分,10分,5分,0分,勇士都令人如此绝望!

· 沪银监局已进驻银行 重点查同业和房贷风险

· 「注意」妈妈做了这件事,造成两岁儿子深二度烫伤!

· 10句话,解千愁

· 神奇的逆光——一组漂亮的逆光摄影及其配诗

· 阿根廷总统马克里访华聊什么?足球合作将是重要议题

· 美国70年前就首飞大客机,卧铺酒吧一应俱全还有美丽的空姐

· 一时的疏忽让宝宝得了鼻窦炎,是我的错!

· 爱一朵花:体贴地把伞偏向你

· 你真我更真,你假我转身

· 你想健康长寿吗?揭秘柴桂仍百岁老人的长寿之道

· 费纳十年,我的网球青春!

· 景甜的双眼皮竟宽得这么恐怖 李宇春纯素颜秒杀章子怡杨幂妆后颜

· 美国半数家庭淘汰固话 中国一年流失2400万座机用户

· 民间“哭丧女”,一个月哭20几天,一个月能挣1万元

· 惊人的巧合造就不可思议的幻想性错觉——你看它们像什么?

· 孔令侃为何不同意与张闾瑛的婚事?

· “微博童书榜”2016十大好书:帮家长甄别童书,享受亲子共读

· 狼人杀好人阵营的核心人物预言家解析

· 一粒米上京

· 官方确认!微信在俄罗斯没法用了,但机智的俄罗斯人却用上了QQ

· 台湾26岁才女作家自杀身亡,她的新书写了遭名师诱奸的亲身经历

· 刘涛在王珂之前,嫁过这么一个人

· 1分钟!9分钟!9分钟!再这样打下去,科尔坐轮椅也要复出执教

· 香港验血性别鉴定为什么可以99.8%准确度

· 中国首家农村办航空公司,资产上亿,包机起价为每人3万多一小时

· 巴菲特住了32年的豪宅探营:估值87万美元,前年请了保安

精彩图片