获取人物坐标,对控制人物事件有着重要的作用(续)

找猫的老鼠   2017-07-04 08:17

前言:对于昨天发的文章在此我深表歉意,由于昨天时间比较张没有来的及给大家解释,所以今天特意来详细讲解一下。

第一步:今天用的是天使插件(设计:一个组合框,5个按钮,前期的工作还是要绑定窗口的,大家先看一下设计窗口)

获取人物坐标,对控制人物事件有着重要的作用(续)

设计窗口

第二步:咱们来看一下绑定窗口事件(这里绑定窗口主要用到了 进程数量 = 进程_枚举 (进程名数组, 进程ID数组) 要 计次循环首 (进程数量, i) 把要用的窗口绑定到 组合框里面,具体看下面图片和代码)

获取人物坐标,对控制人物事件有着重要的作用(续)

寻找窗口1

获取人物坐标,对控制人物事件有着重要的作用(续)

子程序(寻找窗口)

第三步:我们看一下怎么样绑定窗口(用到的是这个:BindWindow (Hwnd, “gdi”, “windows”, “windows”, 101) 不了解的大家可以百度一下)

获取人物坐标,对控制人物事件有着重要的作用(续)

窗口绑定

获取人物坐标,对控制人物事件有着重要的作用(续)

暂停,恢复,结束脚本

第四步:我们来看一下怎么获取人物坐标 这个我用到了找色 TS.FindColor (280, 121, 741, 437, “ff003”, 0.9, 4, ZX, ZY) 解释:280, 121, 741, 437 人物周边的坐标,可以用大漠工具抓图找到, “ff003”这个是血量的颜色,0.9是相似值相对于血量的颜色值来说的,ZX,ZY是变体型。来具体看一下代码:

获取人物坐标,对控制人物事件有着重要的作用(续)

人物坐标

具体代码如下:

.版本 2

.支持库 xplib

.支持库 spec

.支持库 EThread

.程序集 窗口程序集1

.程序集变量 TS, 类_天使

.程序集变量 窗口数组, 整数型, , "0"

.程序集变量 许可证, 线程许可证

.程序集变量 Hwnd, 整数型

.程序集变量 线程句柄, 整数型

.程序集变量 i, 整数型

.程序集变量 k, 整数型

.子程序 __启动窗口_创建完毕

.局部变量 返回值, 整数型

XP风格 (1)

寻找窗口 (“Game.dat”)

返回值 = TS.SetPath (取运行目录 ())

调试输出 (“设置全局录制返回值:”, 返回值)

.子程序 寻找窗口

.参数 进程名, 文本型

.局部变量 进程名数组, 文本型, , "0"

.局部变量 进程ID数组, 整数型, , "0"

.局部变量 进程数量, 整数型

.局部变量 i, 整数型

进程数量 = 进程_枚举 (进程名数组, 进程ID数组)

.计次循环首 (进程数量, i)

.如果真 (进程名数组 [i] = 进程名)

加入成员 (窗口数组, 进程_ID取窗口句柄 (进程ID数组 [i]))

.如果真结束

处理事件 ()

.计次循环尾 ()

.如果真 (取数组成员数 (窗口数组) > 0)

.计次循环首 (取数组成员数 (窗口数组), i)

组合框1.加入项目 (“第” + 到文本 (i) + “窗口,标题:” + 窗口_取标题 (窗口数组 [i]), )

.计次循环尾 ()

组合框1.现行选中项 = 0

.如果真结束

.子程序 _按钮1_被单击

.局部变量 绑定值, 整数型

Hwnd = 窗口数组 [组合框1.现行选中项 + 1]

绑定值 = TS.BindWindow (Hwnd, “gdi”, “windows”, “windows”, 101)

调试输出 (“窗口绑定返回值:”, 绑定值)

.如果 (绑定值 = 1)

许可证 = 线程_创建许可证 ()

线程句柄 = 线程_启动 (&多线程, , )

.否则

信息框 (“窗口绑定失败”, 0, )

.如果结束

.子程序 _按钮2_被单击

.如果真 (线程句柄 > 0)

线程_挂起 (线程句柄)

.如果真结束

.子程序 _按钮3_被单击

.如果 (线程句柄 > 0)

线程_恢复 (线程句柄)

.否则

.如果结束

.子程序 _按钮4_被单击

.局部变量 返回值, 整数型

.如果真 (线程句柄 > 0)

返回值 = TS.UnBindWindow ()

调试输出 (“窗口解除绑定返回值:”, 返回值)

线程_退出许可区 (许可证)

线程_删除许可证 (许可证)

强制结束线程 (线程句柄)

.如果真结束

.子程序 多线程

.局部变量 ZX, 变体型

.局部变量 ZY, 变体型

.局部变量 序号, 整数型

线程_进入许可区 (许可证)

.计次循环首 (100, k)

序号 = TS.FindColor (280, 121, 741, 437, “ff003”, 0.9, 4, ZX, ZY)

调试输出 (“人物坐标返回值:”, 序号)

.如果真 (序号 > -1)

程序_延时 (100)

调试输出 (“人物坐标:”, ZX.取数值 (), “/”, ZY.取数值 ())

跳出循环 ()

.如果真结束

.计次循环尾 ()

' 首先 确定人物坐标

.子程序 _按钮5_被单击

' TS.Capture (0, 0, 1024, 768, “测试.bmp”)

谢谢大家留言互粉!

内容推荐
更多阅读

· 宝宝习惯养成:孩子晚睡并且睡前吃东西怎么办?

· 花10万余元买旧书 80后北漂小伙儿的书店梦

· 小区停车小技巧,小心一不留神中了招

· NBA赛场上“磐涅重生”的球员,泡脚的断腿,利文的涅槃

· LPL夏季赛抽签结束,遭EDG雪藏的Koro1能回第一上单吗

· 夏季带宝宝游泳,妈妈需要了解的小常识

· 城外树林挖出腐烂手臂,我假扮凶手做了件事,让真凶现形

· 全新劳斯莱斯幻影 于明年上市

· 岂止跑得快内里更强大 试驾特斯拉Model S 90D

· 2017网友喊话长安,每台车再降1万吧,反正也不赔钱

· 欧冠决赛关键对决:C罗单挑尤文BBC,水爷PK烟枪

· 斯里兰卡洪水灾害已致193人死亡

· 天美大削宫本武藏40多次 每次削弱照样强大

· 他们在街头过六一 为一线希望与保洁争抢寻子传单

· 美轮美奂洋都天津

· 成都汉墓发掘,重现一段灈锦江边两岸花的流光

· 俄称“诺曼底四国”副外长会谈具有建设性

· 2017世界乒乓球锦标赛混双次轮:方博/索尔佳4-0约内斯库/斯佐茨

· 一边无心恋战,一边解放全中国:解放战争国共差距在理念在思想

· 冠心病患者吃药时间指南

· 在祖国最北军营过端午是怎样一种体验?

· 你只知道莫奈花园,却不知道世界上还有这些惊为天人的植物园

· “中欧电影合拍高峰论坛”:看国内外影视大佬如何谈合拍

· 北京大葱价格上涨超三成 多个产地共同上市价格或下降

· 英国首相突然“失宠” 英镑再次暴跌

· 才女李倩雯,帝师第10代,自己是传奇,祖上代代都是传奇!

· 一代才女“上官婉儿”的上位记

· 谷歌街景10周岁了

· 被表弟陷害,逼上梁山,零污点的好汉

· 苹果,腾讯,阿里,百度卷入移动AR战国时代,最终鹿死谁手?

· 高下立判,大众途昂、辉昂为何冰火两重天?

· 前国脚曾炮轰蔡振华就是三无人员,足协当初曾找他当国足主帅!

· 美国这一系统拦截试验成功反映武器之规律,相生相克促进发展

· 惠发股份6月1日发行 申购上限1.2万股

· 船老板拖欠工资,一海员爬楼讨薪,被民警一把拉回来

· 泉州整治流动摊点、夜市大排档 装高清摄像头24小时全方位监控

· 盘点2017年以色列25家最前沿科技创企,哪家将成为巨头的下一个宠儿?

· 雪铁龙C3 AIRCROSS谍照曝光 有望2018年国产上市

· 温格续约,阿森纳要买买买了!厄齐尔、桑切斯获天价续约合同!

· NASA合作公司老板语出惊人:地球上绝对有外星人

· 众多国宝级文物出土自1700年前幼儿合葬墓,罕见离奇!

· 尤文巨星已获专家指点:想赢皇马 就得这么做!

· AMD正式宣布旗舰游戏卡Vega!压制1080 Ti

· 一财点睛|中国动车组获欧盟认证 海外出口有望加速

· 一财点睛|航天探索大会即将召开 关注深空探测产业

· 二战中德军的防御大师,曾大败朱可夫,自杀后希特勒也效仿

· 境外媒体:缅甸遭美国冷遇 转投中国“温暖怀抱”

· 奠定夯实基础 有了实力还怕上不了王者?

· 五岁女孩坐电动车后座 左脚受伤严重最终致残

· baby新戏开拍又不见踪影!剧组人员说了啥?竟遭杨颖粉丝手撕

· 张柏芝伤情严重,张晋差点毁容,杨紫琼的膝盖已经严重变形!

· 新赛季,曼联阵容大猜想,靠他们就能拼得过曼城切尔西?

· 保监会决定成立偿付能力监管专家咨询委员会

· 狮子狗辅助瞬间满残暴值,上古钱币的隐藏彩蛋

· 四大帝王,个个都是妻管严

· 这才是,每个人最想要的幸福生活!

· 香农-布朗弟弟试训湖人:我能得分和防守

· 台媒:蔡英文应鼓起勇气向“台独”说不

· 预计今天西安最高温33℃

· 《卧底归来》汤镇业全辞商演 张晨光救场不问片酬

· 苹果打赏抽成30%引民愤 罗永浩忍不住骂:傻x

· 日系车、德系车、美系车,车漆到底谁的厚,看完数据你会大吃一惊

· 90后大学生团队为少林寺网店打工月入3000

· 虚假流量导致广告主今年损失约 65 亿美元,这还算比去年好的了

· 如果你是进京赶考的古代书生,路上会遇到这三种情况?

· 泰国央行将采取行动遏制泰铢过度波动

· 中国大推力矢量发动机终于震撼问世,亿万国人激动得欢呼雀跃!

· 民间故事:酒鬼夜宿乱葬岗,路遇泥人鬼糊窟窿,阴差阳错牵线因缘

· 曾经的肉业巨头,如今沦落至“圈地套补”,雨润集团还剩什么?

· 谷歌现在已经能知道你何时进入线下零售店并购买东西了!

· 野史:元明清是被自己诅咒死的?

· 合格的家长让孩子学会:认识自己、接纳自己、控制自己

· 痴人空把落花叹,看尽繁花又是秋

· 辽源西西:夏夜情怀

· 巧夺天工:中国古人艺术之瓶类瓷器美图欣赏

· 高台县公安局城关派出所迅速查处一起阻碍执行职务案件

· 6月英美剧播出一览,看到第一部我就沸腾了!

· Google Play Music新用户福利:免费试用期延长至4个月

· 陆战之王——坦克

· LCK辅助之神Max,不只机器人?还杂耍过许多冷门辅助

· 想当个大人,试试这些定制西装|雅趣

· 沈阳老人西安旅游街头中暑 的哥紧急送医

· 深圳首届当代儿童水墨作品展迎“六一”

· BOSE汽车音响 奥迪A6L魅力展示

· 奥巴马政治遗产将再遭打击?特朗普拟废除美古邦交正常化

· 英媒质疑“中国造”蒙内铁路 肯尼亚人:是你们无知

· Dandy加入北美次级联赛 首度谈起在中国打职业的感受

· 一句话点评4月自主品牌

· 威德马接任新加坡国家游泳队总教练

· 国民党2018誓言夺回台北 群雄扎推参选 他也要出手了

· 美国暂停对台军售 后续变化值得关注

· 端午观鸟正当时 摄影爱好者来津观鸟拍鸟

· 中金岭南:利润改善估值低 高层增持彰显信心

· 中国航母的启蒙舰——“抗美英雄”墨尔本号航母

· V社回复破泞之战推迟:修改跳票 但仍是好游戏

· 爱什么?爱是看见!你真正看见你的孩子了吗?

· 育婴师谈孕妈妈易患感冒怎么办?

· 法网猜想:纳达尔复制费德勒澳网一幕?德穆能否找回状态?

· 王者荣耀高校赛选手曝光某直播平台操纵游戏比赛内幕

· 博山酒鬼刚子

· 无糖黑芝麻戚风——婴儿补钙辅食

· 7.8万让你城市穿梭的哈雷摩托车!STREET 750

· 佛罗伦萨找到队长接班人,巴甲中卫将加盟

· 联盟高管:很难找到一个会准许波什复出的医生

· 白人拳王遭翻版泰森重创致脑出血,不惑之年生命垂危

· 雅百特将投资建设缅甸伊洛瓦底江州

· 传奇投资人Paul Singer:地狱之门将开启,是时候储备弹药了

· 学区房真的能决定孩子的未来?为何家长趋之若鹜

· 调查显示:台民众最不信任记者 官员 民代 法官及领导人

· 蘑菇租房携手支付宝,首推租房行业“交易见证”

· 40万买台迈巴赫,不限行不限号,你值得拥有!

· 伊拉克摩苏尔收复战接近尾声 约20万平民被困

· 富有远见的武后:武周的一项举措若能保留,也许唐朝能再延续百年

· 在博卡拉一定要体验一次滑翔伞 被教练调戏一次

· 让我再跑两圈吧!南京红山动物园两只大熊猫今日回川

· 阿富汗遭连环汽车炸弹袭击:至少60死伤 波及中方机构

· 前英超MVP递交转会申请:我有野心不想蹉跎岁月

· 黎巴嫩军方接受法国军事援助 排爆犬成“大礼”深受欢迎

· 美国退伍军人组织在白宫外游行 抗议特朗普政府政策

· 巴拿马前政府首脑曼努埃尔·诺列加去世 媒体在医院外守候

· 《法律与秩序:真实罪案》确定“梅内德斯兄弟”扮演者

· 关于SaaS,你听说的那些,可能都是谣言!

· 头条打开率25%一年164篇10w+,内容老兵如何玩公众号?

· 曝新款比亚迪唐疑似价格/配置 或推两款车型

· 体验|市面上唯一的六座小型SUV,猎豹CS9买车还送“电视”

· 官方:鹿岛鹿角主帅石井正忠下课

· 核心产值4584亿 投资人在投资“泛娱乐”时都想些什么?

· 中国古代才女大盘点 之 多才风雅的上官婉儿

· 为实现朝韩对话,文在寅这次不惜打脸安倍特朗普

· 《神奇女侠》获IGN评分7.9 超级女英雄拯救了DC宇宙

· 回忆:盘点大多数人童年玩过的玩具和游戏,你玩过几个呢?

· 利好出尽要轻仓,站稳均线再入场

· 《四圣心源》《圆运动》在中医里有多重要?来看看这些观点

· 榆林一公司蛋鸡死亡确诊H7N9 疫点疫区实施21天封锁管控

· 两款“迪士尼”童鞋检出有害物质 影响男童生殖系统发育

· 亚马逊股价首次突破1000美元

· 只要迈出第一步(民间故事)

· 孩子几岁跟爸妈分床早睡最好?这才是最好的答案

· 1992年中国围棋发生了什么 聂卫平马晓春对抗赛力胜日将

· 广东一老头买女子续香火 生完儿子后转手卖给别人

· 生母失联5岁留守女童成黑户,湖北民警如山档案中找到出生证

· 配合端午节 马来西亚总理祝福华裔合家平安团圆

· 昌吉这隐蔽小院已彻底“火”!去的人都扶着墙进,扶着墙出……

· 足球——法国杯:巴黎圣日耳曼夺冠

· 记账嫌麻烦?不如让「网易有钱」自动帮你记

· 顺应“7座”风潮 测东风日产奇骏7座版

· 荐酒|3款高性价比名门好酒,清新又好喝

· 曾经的肉业巨头,如今沦落至“圈地套补”,雨润集团还剩什么?

· 看见男子拖着一女子进了屋 原来竟是毒瘾发作

· 分手9年后一起录节目,林心如立刻向林志颖索要悍马手表做礼物!

· 菲律宾主帅雷耶斯:准备击败中国

· 三个神奇的成语,同时具有褒义和贬义,在成语里并不多见

· 从法拉利来的新CEO会带领兰博基尼走向新的辉煌吗?|专栏

· 被 AI 操纵的完美人生,让你赢在最终点

· 三明这些老赖欠款数千万最高上亿 被公开曝光

· 售25.18万元 五十铃mu-X新增车型上市

· 励志!曼城妖王忆苦思甜 3年前还在街头刷油漆

· 八千里路的徒步修行:福建泉州开元寺到山西忻州五台山的朝拜

· 可推断彼此关系的最牛摄像头!人工智能可以帮你监控一切!

· 蓝天烈日下的“橄榄绿”,探访长安街武警巡逻哨兵

· 普京:盼与美就叙问题展开切实对话 而非空谈主张

· 宝宝突然鼻子嘴巴周围乌青,哭闹不止,难道被鬼打了吗?

· 城里姑娘心中有个农场,于是从村里租了个院子过起村姑的生活

· 香港露营游记,行走在爱与恨的边缘:中西文化融为一体的城市

· 醉酒乘客不守规则大闹飞机 被机组人员制服赶下飞机

· 抚顺一男子低价购买的“抵押车”被当街抢走

· 熊壮一家:44人大家庭“几十年没闹过矛盾”

· 独家揭秘从《一代风流宋耀如》到《宋耀如·父亲》背后的故事

· 分别在六月,再见我的军校,再见我的兄弟!

· 中国斯洛文尼亚建交25周年纪念封上的文化遗产

· 小话 屈原

· 你以为如今的地球还是想象中的那么漂亮吗?

· 科温顿牙买加度假:理清大脑的完美方式

· 美军伞兵用啥步枪?咋训练得那么能打的?都不是白给的呀

· 激萌“小洋人”名流圈 潮童出街LOOK融化你的心

· 乐天玛特撑不住了?或抛售中国店铺“大瘦身”

· 不再傻傻分不清,教你一眼分辨雪铁龙世嘉、C4L、C4世嘉!

· 老照片:1911年老北京街景实拍

· 进城农民靠摩的为生,常年在地铁口笑脸相迎趴活

· 他助父子相继篡位成功,子皇帝登基后痛哭流涕不肯原谅他

· 获捐100多万 那个乞求“把我埋了吧”的宝宝还是走了

· 当你老了 怎样才有高质量的晚年?

· 埃泽利晒图祝哈里森-巴恩斯25岁生日快乐

· 西咸新区丝路经济带能源金融贸易区

· 为什么人寿保险不让一次性缴清十年的保费?

· 中国第一艘核潜艇的舱室布局你知道吗?

· 环球经济7日汇|05.19-05.26

· 官方部署汛期煤矿防治水:排水不达标一律停产

· 王者荣耀最强玩家,用扁鹊78连胜98%胜率上王者

· 如果你家女宝有这4个特征,那可是美人胚子的标志哦

· 270平米台湾大宅 装修格调比内地土豪高三倍

· 国足备战叙利亚名单恒大8人 于汉超终被里皮征召

· 联想集团正计划私有化?官方回应;亚马逊股价首次破1000美元

· 国轩高科获北汽新能源18.75亿元大合同

· 保隆科技打开一字涨停 累计上涨150.11%

· 开创了空军战史上活塞式驱逐机击落喷气式驱逐机的开国大校徐兆文

· 《绝地求生大逃杀》四倍镜正确用法图文教程

· LOL符文天赋要改版啦:新符文免费用,有补偿你还满意吗?

· 租个男人去旅游(民间故事)

· 台湾县市长施政满意度调查:国民党谷底翻升 朱立伦获最佳进步奖

精彩图片